configure: error: utf8_mime2text() has new signature, but U8T_CANONICAL is missing.

Posted in Новости on сентября 16, 2013 by admin


apt-get install libc-client2007e-dev

Tags: , , , ,

После апдейта отсутствует grub.cfg в /boot/grub/

Posted in Новости on января 18, 2013 by admin

После апдейта с Debian 5 на Debian 6 отсутствует конфиг обновленного граба. В большинстве случаев это не так критично, ведь сервер сможет загружаться и с menu.lst, но старый конфиг не поддерживает работу с GPT разделами.
Генерация grub.cfg :

update-grub

Tags: , , ,

Проблема при установке mysql через puppet модуль

Posted in Новости on ноября 21, 2012 by admin

После установки MySQL поддержки плагина для puppet и при апдейте конфигурации на клиенте возникает ошибка :

Unsupported osfamily: operatingsystem: Debian, module mysql only support osfamily RedHat, Debian, and FreeBSD, or operatingsystem Amazon at /etc/puppet/modules/mysql/manifests/params.pp:111 on node

То есть по сути система определилась верно, но отрабатывать правильно модуль не хочет. В ходе расследования было выявлено, что имя системы берется из переменной окружения osfamily утилиты facter.

Хотя утилита и показывает верную ОС, но проблемы это не решило до тех пор, пока я не обновил facter до версии 1.6.9 из backports


apt-get install facter -t squeeze-backports

Tags: , , , , ,

Неинтерактивная установка софта в Debian like системах

Posted in Новости on сентября 21, 2012 by admin

В случае, если требуется установить postfix или тот же phpmyadmin, через скрипт или если недоступен монитор, то возникает проблема ввиду того, что при установке конфигуратор запрашивает у нас данные интерактивно. Избежать этого можно, просто добавив новый параметр окружения. Например, ставим postfix :

DEBIAN_FRONTEND='noninteractive' apt-get install -y -q —force-yes postfix

Tags: , , , ,

Даунгрейд пакетов Debian

Posted in Новости on августа 15, 2011 by admin

Допустим мы поставили iftop из squeeze ( 0.17-16 ), но нам срочно нужна версия из lenny .

electron:~# dpkg -l | grep iftop
ii iftop 0.17-16 displays bandwidth usage information on an n

Проверяем версию пакета из нужной версии ОС
http://packages.debian.org/ru/squeeze/iftop

Меняем репозитории на нужные
sed -i 's/squeeze/lenny/' /etc/apt/sources.list

Обновляем кеш пакетов
apt-get update

Ставим нужную версию
electron:~# apt-get install iftop=0.17-8
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages were automatically installed and are no longer required:
libterm-readkey-perl
Use 'apt-get autoremove' to remove them.
The following packages will be DOWNGRADED:
iftop
0 upgraded, 0 newly installed, 1 downgraded, 0 to remove and 11 not upgraded.
Need to get 33.3kB of archives.
After this operation, 36.9kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 ftp://mirror.hetzner.de lenny/main iftop 0.17-8 [33.3kB]
Fetched 33.3kB in 0s (381kB/s)
dpkg — warning: downgrading iftop from 0.17-16 to 0.17-8.
(Reading database … 65586 files and directories currently installed.)
Preparing to replace iftop 0.17-16 (using …/iftop_0.17-8_amd64.deb) …
Unpacking replacement iftop …
Processing triggers for man-db …
Setting up iftop (0.17-8) …

electron:~# dpkg -l | grep iftop
ii iftop 0.17-8 displays bandwidth usage information on an n

Соответственно если у пакета есть зависимости ( не основные библиотеки системы типа libc6 ), то пробуем сначала откатить через aptitude , либо откатываем все требуемые пакеты до своих версий.

Tags: , ,