Даунгрейд пакетов Debian

Допустим мы поставили iftop из squeeze ( 0.17-16 ), но нам срочно нужна версия из lenny .

electron:~# dpkg -l | grep iftop
ii iftop 0.17-16 displays bandwidth usage information on an n

Проверяем версию пакета из нужной версии ОС

Меняем репозитории на нужные
sed -i 's/squeeze/lenny/' /etc/apt/sources.list

Обновляем кеш пакетов
apt-get update

Ставим нужную версию
electron:~# apt-get install iftop=0.17-8
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages were automatically installed and are no longer required:
Use 'apt-get autoremove' to remove them.
The following packages will be DOWNGRADED:
0 upgraded, 0 newly installed, 1 downgraded, 0 to remove and 11 not upgraded.
Need to get 33.3kB of archives.
After this operation, 36.9kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 ftp://mirror.hetzner.de lenny/main iftop 0.17-8 [33.3kB]
Fetched 33.3kB in 0s (381kB/s)
dpkg — warning: downgrading iftop from 0.17-16 to 0.17-8.
(Reading database … 65586 files and directories currently installed.)
Preparing to replace iftop 0.17-16 (using …/iftop_0.17-8_amd64.deb) …
Unpacking replacement iftop …
Processing triggers for man-db …
Setting up iftop (0.17-8) …

electron:~# dpkg -l | grep iftop
ii iftop 0.17-8 displays bandwidth usage information on an n

Соответственно если у пакета есть зависимости ( не основные библиотеки системы типа libc6 ), то пробуем сначала откатить через aptitude , либо откатываем все требуемые пакеты до своих версий.

Tags: , ,

Leave a Reply